Home Forums Pianobook Help with looping on Decent Sampler

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1748
    Christopher Vela
    Participant

    Hello to everyone, I’m new to sampling and making virtual instruments
    i am currently working on a loop base library
    but i did not make the loop marks into the samples so i am trying to use de sampler engine to
    set the loops, according to the documentation i must use some attributes
    but surely im doing something wrong, Can anyone please would help me?
    here is the code of my instrument.

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <DecentSampler>
    <ui bgImage=”background.png” width=”812″ height=”375″ layoutMode=”relative”
    bgMode=”top_left”>
    <tab name=”main”>
    <labeled-knob x=”560″ y=”0″ label=”Tone” type=”float” minValue=”60″ maxValue=”22000″
    textColor=”FF000000″ value=”22000.0″ uid=”y8AA4uuURh3″>
    <binding type=”effect” level=”instrument” position=”0″ parameter=”FX_FILTER_FREQUENCY”/>
    </labeled-knob>
    <labeled-knob x=”655″ y=”0″ label=”Reverb” type=”percent” minValue=”0″ maxValue=”100″
    textColor=”FF000000″ value=”50.0″ uid=”lKv29kggDro”>
    <binding type=”effect” level=”instrument” position=”1″ parameter=”FX_REVERB_WET_LEVEL”
    factor=”0.01″/>
    </labeled-knob>
    </tab>
    </ui>
    <groups attack=”0.000″ decay=”25″ sustain=”1.0″ release=”0.430″ volume=”0.dB”>
    <group>
    <sample loopEnabled=”true” loopStart=”0″ loopEnd=”000,307,0,94″ loNote=”21″ hiNote=”21″ rootNote=”21″ path=”Stopwatch drum and bass loop.wav”
    length=”805888″/>
    </group>
    </groups>
    <effects>
    <effect type=”lowpass_4pl” frequency=”22000.0″/>
    <effect type=”reverb” wetLevel=”0.4999999888241291″/>
    </effects>
    </DecentSampler>

    #2984
    Sid
    Participant

    Hi,
    You definitely don’t want the commas in there, so this:

    <sample loopEnabled=”true” loopStart=”0″ loopEnd=”000,307,0,94″ loNote=”21″ hiNote=”21″ rootNote=”21″ path=”Stopwatch drum and bass loop.wav”
    length=”805888″/>

    should be:

    <sample loopEnabled="true" loopStart="0" loopEnd="307094" loNote="21" hiNote="21" rootNote="21" path="Stopwatch drum and bass loop.wav"
    length="805888"/>

    Also I found your quotation marks not to be standard (maybe this was just an artifact of pasting to this forum). Be sure you are using a plain text editor like notepad on windows or TextEdit on Mac, and do not save in RTF (rich text format).

    That will assign the key A0. Also, be sure the path is from wherever this file is saved to the samples. If you have the samples in a subfolder called “samples” for example, use path=”samplesStopwatch drum and bass loop.wav”

    #2988
    Christopher Vela
    Participant

    Ohhh i see!! Thanks a lot
    Mr, Sid

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.