Decent Sampler – Binding knob to reverb issue

Home Forums Pianobook Decent Sampler – Binding knob to reverb issue

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1009629
    AvatarRaul Yebra
    Participant

    Hi,
    I’m creating my first DS instrument and I’m struggling with the bindings (when I move the knob I don’t hear the difference).
    Maybe I’m missing something?
    This is the dspreset code:
    <?xml versio`n=”1.0″ encoding=”UTF-8″ ?>
    <DecentSampler>

    <ui bgImage=”background.png” width=”812″ height=”375″>
    <tab name=”main”>
    <labeled-knob x=”301″ y=”20″ width=”200″ height=”200″ label=”Reverb” type=”float” minValue=”0″ maxValue=”100″ textColor = “FF000000” value = “50” textSize = “20”>
    <binding type=”effect” level=”instrument” position=”1″ parameter=”FX_REVERB_WET_LEVEL” factor=”0.01″/>
    </labeled-knob>
    </tab>
    </ui>

    <groups>
    <group valume=”1.0″ ampVelTrack=”20″>
    <sample path=”samples/E1.wav” rootNote=”40″ loNote=”34″ hiNote=”40″ loVel=”0″ hiVel=”90″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/B1.wav” rootNote=”47″ loNote=”41″ hiNote=”47″ loVel=”0″ hiVel=”90″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/Gb2.wav” rootNote=”54″ loNote=”48″ hiNote=”59″ loVel=”0″ hiVel=”90″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/D3.wav” rootNote=”61″ loNote=”60″ hiNote=”62″ loVel=”0″ hiVel=”90″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/G#3.wav” rootNote=”68″ loNote=”63″ hiNote=”88″ loVel=”0″ hiVel=”90″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    </group>
    <group valume=”1.0″ ampVelTrack=”50″>
    <sample path=”samples/e E1.wav” rootNote=”40″ loNote=”34″ hiNote=”40″ loVel=”61″ hiVel=”127″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/e B1.wav” rootNote=”47″ loNote=”41″ hiNote=”47″ loVel=”61″ hiVel=”127″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/e F#2.wav” rootNote=”54″ loNote=”48″ hiNote=”54″ loVel=”61″ hiVel=”127″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/e C#3.wav” rootNote=”68″ loNote=”55″ hiNote=”61″ loVel=”61″ hiVel=”127″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    <sample path=”samples/e D3.wav” rootNote=”62″ loNote=”62″ hiNote=”88″ loVel=”61″ hiVel=”127″ tunning=”0″ volume=”1″ pan=”0″ trigger=”attack” />
    </group>
    </groups>

    <effects>
    <effect type=”reverb” roomSize=”1.0″ damping=”0.0″ wetLevel=”1.0″ />
    </effects>

    </DecentSampler>`

    #1011352
    AvatarSid
    Participant

    <binding type=”effect” level=”instrument” position=”1″ parameter=”FX_REVERB_WET_LEVEL” factor=”0.01″/>
    Should be:
    <binding type=”effect” level=”instrument” position=”0″ parameter=”FX_REVERB_WET_LEVEL” factor=”0.01″/>

    The code is zero based, so the first position=”0″.

    #1012483
    AvatarRaul Yebra
    Participant

    Thanks! Working perfectly now ^_^

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.

Follow Pianobook